Integrating blog posts with forums

File under “small victories”:

Publishing new blog posts now creates a new post in the Blog category (https://discourse.saylor.org/c/blog).

Replies within these forums display on the the blog post itself and readers of the blog post are invited to “start” or “continue” the conversation here in the forums.

You can see this in action by scrolling to the bottom of this post (older posts still use WordPress for commenting, at the moment).

Pros

  • Blog posts are automatically syndicated to the forums. Since we use blog posts to make announcements, this allows us to gain a wider audience for announcements.
  • Adding posts creates more content and opportunity for discussion here in the forums.
  • Creates a more integrated user experience.
  • Encourages people to create a forums account.

Cons

  • Commenting on blog posts can only be done via these forums, which means one must have a forums account to post. This makes it less likely that those outside, or mostly outside, our community will share comments.
  • Interacting with a blog post by adding a new comment requires coming over to the forums. The creators of Discourse consider this a feature, not a bug, however – Discourse is meant to be interacted with directly rather than through being embedded elsewhere.
  • Could encourage creation of spam accounts here in the forums. We have not had much problem with that, but WordPress (which is what runs our blog) is a HUGE target for comment spam.

So keep an eye on the Blog category and please reply as desired – we will be watching there!

1 Like

Hi @seanconnor

This great feature of “Integrating [Saylor] blog posts with [Saylor Discourse] forums” that you announced in your post above, dated December 11, 2015 - Integrating blog posts with forums - seems to have stopped working (at least, that’s what I noticed today, July 28, 2016).

What do I mean by that? I mean that:

Was this change intentional or is it due to some issue (like human error - hey, it happens to the best of us! - or some kind of “bug”)?

1 Like

Hi again @seanconnor :slight_smile:

I see that this issue - of the integration of blog posts with forums that stopped working - was solved today (August 1, 2016):

Thank you very much for fixing this problem! :slight_smile:

Bug! This function is implemented with a Discourse plugin for Wordpress – I think one of the major Discourse updates might have broken the plugin, so we had to update the plugin and then check the various settings to get it to fire again.

Although I’ve been inexcusably mostly-absent from the forums recently, I did update this because I saw your message above, so thank you.

Hopefully, it won’t cause any more trouble any time soon!

1 Like

Hi @sean ,

This great feature of “Integrating [Saylor] blog posts with [Saylor Discourse] forums” that you announced in your post above, dated December 11, 2015 - Integrating blog posts with forums - seems to have stopped working again, possibly since the Saylor Academy’s site redesign
that was made on November 2018 (https://www.saylor.org/2018/11/blog-saylor-academy-is-getting-a-new-look/).

Could you and/or any other of your Saylor colleagues check / comment about this, please?